Static routing on Cisco devices

Well, there is numerous situations where you can use static routing. I know, that in large networks this technology is not very popular, but there are lot of situations where you will be forced to use it.

Start with topology overview  such is in slide bellow (Slide 1).

Static routing on Cisco devices

Slide 1.

First configure interfaces to LAN`s and interconnection between routers:

R1(config)#interface fa0/1
R1(config-if)#ip address 192.168.200.1 255.255.255.0
R1(config-if)#description LAN_R1
R1(config-if)#no shutdown

R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.100.1 255.255.255.0
R1(config-if)#description R1_R2
R1(config-if)#no shutdown

R2(config)#interface fa0/1
R2(config-if)#ip address 192.168.250.1 255.255.255.0
R2(config-if)#description LAN_R2
R2(config-if)#no shutdown

R2(config)#interface fa0/0
R2(config-if)#ip address 192.168.100.2 255.255.255.0
R2(config-if)#description R2_R1
R2(config-if)#no shutdown

You can verify interconnection between routers using ICMP. From R2 you can ping R1 on interconnected interface:

R2#ping 192.168.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

If succeeded to ping other side, now you can configure static routing on both sides. Static routing is basically unidirectional process but it has to be configured on both sides. Enter route to LAN`s on the other side following by network subnet mask and next hop. In stub networks you can use self hop interface.:

R2(config)#ip route 192.168.200.0 255.255.255.0 192.168.100.1

R1(config)#ip route 192.168.250.0 255.255.255.0 192.168.100.2

Now you can verify your configuration  by using ICMP and using show ip route command:

R1#ping 192.168.250.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.250.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/28 ms

 

R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C    192.168.200.0/24 is directly connected, FastEthernet0/1
S    192.168.250.0/24 [1/0] via 192.168.100.2
C    192.168.100.0/24 is directly connected, FastEthernet0/0

When you verified connectivity you can proceed with  configuring you network.

I hope that this tutorial was informative to you and thank you for visiting this website.

Dejan Dzodan

Dejan Dzodan

IT professional for more then 15 years, mostly in financial institutions but with experience in ISP and retail. Proven in networking and overall infrastructure projects. Cisco instructor.

Leave a Reply

Your email address will not be published. Required fields are marked *


1 + 7 =